//Comandos CISCO IOS, um auxilio para a Certificação

Comandos CISCO IOS, um auxilio para a Certificação

Aqui estão os comando mais importantes que você precisa saber
juntamente com como aplicá-los ao equipamento Cisco.

Cada comando está com um link para sua melhor visualização com um exemplo prático e como ele será executado.

Comandos sem Privilégios

enablelockping
telnettracerouteresume
disconnectsshexit

Comandos com Privilégios

configure terminaldebugsetup
copy running-config startup-configerase startup-configwrite
clock setclearreload
write terminalundebug allcopy tftp startup-config
copy running-config tftpcopy tftp running-configcopy startup-config running-config
terminal monitorcopy startup-config tftp

Comandos de Configuração

ip domain-lookupnohostname
config-registerclock timezonealias exec
logging consoledodefault interface
interfacerouterusername
ip classlessip subnet-zeroip default-gateway
ip dhcp poolenable secretip domain-name
ip hostip http serverip name-server
ip routeaccess-list (standard)access-list (extended)
ip access-listservice password-encryptioninterface loopback
endlogging bufferedbanner motd
router riprouter eigrp <As>router ospf <process id>
ip nat poolip nat inside source listip nat inside source static
ip dhcp excluded-addressenable password

Comandos de Interface

ip addressclock rateencapsulation
bandwidthdescriptionduplex
no shutdown / shutdownencapsulation dot1qkeepalive
ip access-groupip bandwidth-percent (EIGRP)ip directed-broadcast
ip helper-address (DHCP)ip mtuip ospf #
ip ospf costip ospf priorityip ospf network broadcast
ip ospf network nonbroadcastip ospf network point-to-pointip ospf network point-to-multipoint
ip ospf hello-intervalip ospf dead-intervalcdp enable
ip rip sendip rip receivespeed
mac-addressip split-horizon (RIP)ip split-horizon eigrp <As>
encapsulation pppppp authentication chapppp chap hostname
ppp chap passwordppp pap sent-usernameencapsulation frame-relay
frame-relay interface-dlciframe-relay map ipframe-relay inverse-arp
ip nat insideip nat outsideip nat enable
ip address dhcpppp authentication papdelay

Comandos de Linha de Console

logging synchronousloginhistory size
exec-timeoutlengthlockable
passwordprivilege

Comandos de Linha VTY

logging synchronousloginhistory size
exec-timeoutlengthlockable
passwordprivilegeaccess-class

Comandos de Exibição

show access-listsshow Running-configshow startup-config
show running-config Interfaceshow Clockshow controllers
show debugshow frame-relay mapshow frame-relay pvc
show frame-relay lmishow hostsshow interfaces
show ip interfacesshow ip interfaces briefshow sessions
show tech-supportshow ip access-listsshow ip dhcp binding
show ip dhcp conflictsshow ip dhcp poolshow dhcp server
show ip eigrp interfaceshow ip eigrp neighborsshow ip eigrp topology
show ip ospf interfaceshow ip ospf interface briefshow ip ospf neighbor
show ip ospf databaseshow ip routeshow ip route rip
show ip route eigrpshow ip route ospfshow ip route connected
show ip nat translationsshow ip nat statisticsshow ip protocols
show cdp neighborsshow cdp neighbors detailshow dhcp lease
Filtering Output *

Comandos de Router RIP

version 2no auto-summarynetwork
passive-interfacevalidate-update-sourcepassive-interface default
maximum-pathsdistribute-listoffset-list
distancetimersneighbor

Comandos de Router EIGRP

no auto-summarynetworkdistance
distribute-listeigrp router-idpassive-interface
passive-interface defaultvariance (EIGRP)offset-list
distance eigrpmaximum-pathsneighbor

Comandos de Router OSPF

network
passive-interfacerouter-idpassive-interface default
maximum-pathsdistribute-listauto-cost reference-bandwidth
distancedistance ospfneighbor

Comandos Debug

debug ip packetdebug ip packet detaildebug ip routing
debug ip eigrpdebug ip ospf adjdebug ip ospf events
debug ip ospf packetdebug ip rip

Comandos Clear

clear ip route *clear ip ospf processclear ip eigrp neighbors

Switch Commands

Comandos de Privilégios

vlan databaseconfigure

Comandos de Vlan Database

vlanexitshow
vtp domainvtp pruningvtp server
vtp clientvtp transparentvtp password
apply

Comandos de Configuração

vlaninterface vlaninterface range
vtp mode servervtp mode clientvtp mode transparent
vtp domainvtp passwordspanning-tree backbonefast
vtp pruningspanning-tree portfastip default-gateway
spanning-tree vlan root primaryspanning-tree vlan root secondaryspanning-tree vlan priority
spanning-tree uplinkfast

Comandos de Interface

switchport mode accessswitchport mode trunkswitchport nonegotiate
spanning vlan costswitchport trunk encapsulation dot1qswitchport trunk encapsulation isl
switchport trunk native vlanspanning-tree port-priorityswitchport trunk allowed vlan
switchport access vlanswitchport port-securityswitchport port-security mac-address
spanning-tree vlan port-priorityswitchport port-security maximumswitchport port-security violation
spanning-tree costspanning-tree guard root
spanning-tree portfast

Comandos de Exibição de Interfaces

show vlanshow vlan briefshow interface trunk
show spanning-treeshow spanning-tree vlanshow vtp status
show port-secshow mac-address-tableshow interface

Comandos de Combinação de Teclas

TabReturn (at the –More– prompt)space Bar (at the –More– prompt)
Ctrl-FEsc-BEsc-F
Ctrl-ACtrl-ECtrl-D
Esc-DCtrl-WCtrl-K
Ctrl-U or Ctrl-XUp Arrow or Ctrl-PDown Arrow or Ctrl-N
Ctrl-YCtrl-ZCtrl-shift-6, x

Sou Analista de Sistemas Bacharel em Sistemas da Informação, Certificado MCTS 70-680 / MOS, Trabalho como Administrador de Redes e Servidores Windows e Linux! Minhas atividades favoritas são: Caminhar, Fazer Trilhas, Natureza, Insetos e claro ler sobre Tecnologia.